Resolve the dependency: libnss3-1d while installing Google Chrome in Ubuntu

Recently, I switched to new version of Ubuntu 11.04. When It is newly released distro, it has some bugs. I faced it when I tried to install Google Chrome. It showed me as error message: chromium-browser: Depends: libnss3-1d (>= 3.12.3). libnss3-1d is a set of libraries of Network Security Services (NSS), which is basically designed to support cross-platform development of security-enabled server applications. So, I resolved this dependency:libnss3-1d and then installed Google Chrome.. Let me share the way of fixing this dependency.

Download the libnss3-1d by typing in command line

wget http://security.ubuntu.com/ubuntu/pool/main/n/nss/libnss3-1d_3.12.9+ckbi-1.82-0ubuntu0.8.04.1_amd64.deb

If your pc is Intel x86 machines, then type following line

wget http://security.ubuntu.com/ubuntu/pool/main/n/nss/libnss3-1d_3.12.9+ckbi-1.82-0ubuntu0.8.04.1_i386.deb

Then, run the this command

sudo dpkg -i libnss3-1d*.deb

By the way way, before installing Chrome, make sure installed Adobe Flash Player. If you installed Adobe Flash Player from Adobe website, you may have some broken packages. So fix them first ..

sudo apt-get install -f

Done..!! Now try the installation. Enjoy Google Chrome in new Ubuntu 11.04.

 

Eftakhairul Islam

Hi, I'm Eftakhairul Islam, a passionate Software Engineer, Hacker and Open Source Enthusiast. I enjoy writing about technical things, work in a couple of startup as a technical advisor and in my spare time, I contribute a lot of open source projects.

 

Leave a Reply

Your email address will not be published. Required fields are marked *

 

Read previous post:
Install software in Ubuntu 11.04 Natty Narwhal using the Ubuntu 10.10 Partner repository

Recently I upgraded my OS from Ubuntu 10.10 (Maverick Meerkat) to 11.04 (Natty Narwhal). But I am having problem installing...

Close